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Conventions used in this manual 
To enable you to use the information in this guide effectively, you need to understand the conventions used in 
the guide to represent differing types of information. 
 

• Buttons on the screen are represented as the button text in square brackets. 
For example: Click on [OK]. 

• Keys on the keyboard are represented as bold lettering in between < > characters. 
For example: Press <Enter>. 

• Ribbon Tab options are represented as a path with the Ribbon Tab in UPPER case with sub menus 
Capitalised and separated with an arrow  
For example: Select FILE > Open. 

• Field names are represented as bold text. And the value to be entered will be represented by Bold 
Text. 
For example: Enter the value 50 in the Offset field. Or 
When prompted for the X & Y values type 100,50 <Enter> 

 Denotes a <LClick> or Primary Mouse Button Click. 

 Denotes a <RClick> or Secondary Mouse Button Click. 

 This is a note. It contains useful or additional information. 
 

 This is a reference. It directs you to another part of the user guide. 
 

 This is a thought box. It is generally used in exercises and contains a question for you to 
consider. 

 This is a highlighted note to emphasise information 

 This is a warning; it contains information that you must not ignore. 

 This is a tip. It is generally used in exercises and offers further advice. 
 

1. This is the first line of a number list item 

2. This is the second item of the numbered instructions, which you must 

3. Follow in sequence. 

• This is a list 

• of items, in which 

• The order is not important.  
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Recommended Operating Systems and Hardware for 
ALPHACAM 

Supported Operating Systems  
• Operating System  

• 64bit operating systems of the following list are supported,  

• Windows 7 (Professional, Enterprise or Ultimate) SP1 required, 

• Windows 8.1 Professional and Enterprise, 

• Windows 10 Professional and Enterprise. 

• ALPHACAM will install and run on the 'Home' editions of the above operating systems. However, this 
is not recommended, and we cannot guarantee to fix any ALPHACAM issues specifically related to 
these operating systems. 
 

• Nvidia or ATI Open GL Graphics Card with 1Gb dedicated memory  

 We recommend you keep up to date with the with the latest Software Updates for the 
supported operating systems and drivers for your hardware base. 
 

 Any Windows Operating system (OS) prior to and including Vista, is not a supported 
operating system. 

ALPHACAM Minimum Specifications 

 The latest minimum specification can be found at 
http://www.alphacam.com/systemrequirements 

 
This minimum specification is to run any Alphacam Essential module, you will need to considerably increase 
the specification if you are working with solid models and producing the NC code for 3D machining and 3, 4, or 
5 axis simultaneous machining strategies. 
 
Your minimum specifications should be the fastest processor with the most memory and the highest 
specification video card that your budget will allow. 
 

 If using Autodesk Inventor Files, please check the current Inventor View requirements at 
autodesk inventor view   

http://www.alphacam.com/systemrequirements
http://www.alphacam.com/systemrequirements
http://www.alphacam.com/systemrequirements
https://customers.ps.hexagonmi.com/Site/Support/SoftwareDownload.aspx
http://www.alphacam.com/systemrequirements
https://www.autodesk.co.uk/viewers/all-viewers/compare
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Hexagon Customer Portal 
At Hexagon, we strive to provide you and your business with first class technical support and services. The 
Customer Support Portal allows you the tools you need to receive the best from your software. In addition to 
generating new and updating existing support cases, the portal allows you: 
 

• Unlimited user logins for your company. 

• Access to all your licenses for easy reference. 

• Get the latest releases and software update at the touch of a button. 

• View what is available on your support and maintenance schedule. 

• Reference to the Customer Support Charter at any time. 

• View the status of your Technical Support cases. 

• View all purchased Professional Services like Training and Consultancy. 

 

 
Figure 1 - Customer Support Portal 

For the Hexagon Customer Portal visit customers.ps.hexagonmi.com 

https://customers.ps.hexagonmi.com/default.aspx
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ALPHACAM esupport 
Another location to gain valuable information about using the software or asking other experienced users for 
assistance are the esupport forums. 

 

 
Figure 2 - esupport page 

 
Asking a question of the community, using the knowledge base or other available information links could save 
you time if you have a problem that someone else may already have supplied a solution for. 
 
 
 
 

 

http://esupport.verosoftware.com/alphacam/
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This drawing is the part you are going to create.  
 

 

 

 
Figure 3 - Housing Plate Main Drawing Details 

ALPHACAM provides many ways of creating part geometry, however for the purposes of these notes we will 
be using only CAD style geometry creation, whereby individual geometric features are created and then 
trimmed to create geometric contours. Toolpaths are then applied to the geometric contours from which the NC 
program is produced. 
 
CAD style geometry creation mainly utilises the Line, Arc, Circle and Rectangle commands; however, 
ALPHACAM also includes “Special Geometries” which automatically produces standard geometric shapes. 
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Figure 4 - Housing Plate reference model 
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THE PROCESS PLAN 
As per the job process you should create a machining process plan prior to creating the geometric profiles. It is 
the process plan that determines which geometry is required to control the machining. In this example, we can 
assume that all the geometry is required for machining. 
 
Prior to creating the geometry, it is good practice to produce outline notes about the geometry to be defined. 
In this case for clarity we will number the profiles to be drawn. 
 

 
Figure 5 - Housing Plate Geometry Constituent Parts 

 
 

Drawing Layer Structure 
To allow for ease of manipulating the final drawing and adding machining we will create a structure of User 
Layers for the geometry to be created on. 
 
User Layers are extremely useful as your drawings progress in aiding you visually using differing colours for 
different items as well as making the hiding and showing of geometries easier.  
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Constituent parts 
1. Datum Position centre of circle profile 9. 

2. Outer Profile same as profile 2 but 8mm offset larger, with Ø8 holes and R12 lugs with 5mm fillets. 

3. Closed profile made up of 2 circles R55 and R102 and 2 tangent lines. 

4. 9 holes Ø6, equally spaced on profile 8mm offset inside of profile 2 starting at left most quadrant point. 

5. Ø10mm chamfer circle at centre of 13mm fillet. 

6. Ø6mm circle at centre of 13mm fillet. 

7. Figure of 8 with circles R38 & R82, with 3off R22 indents on Ø180 circle, 5mm fillets to indents plus 
2off 13mm radius fillets. 

8. Circle offset 6mm bigger than circle profile 9. 

9. Circle offset 6mm bigger than circle profile 10. 

10. Circle Ø20. 

11. Circle Ø30. 

12. 3mm Arial Font text “Part No 27854” centred on R82 radius guide line. 

Order of Production 
Draw the Profiles in the following order; 
9 & 10, 7 & 8, 6, 2, 3, 1, 5, 4, 11 
 

 The order listed for drawing is based on the given information on the drawing in that you 
are unable to create certain geometry items until others have been drawn first. 
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CREATING THE GEOMETRY 

Profiles 9 & 10 
2 off circles Ø20 and Ø30. 

 
Figure 6 - Profile 9 & 10 

Create and activate the User Layer 
From the Layer page of the Project Manager, <RClick> on the entry User Layers. 

 
 
Figure 7 - Adding the first User Layer 

From the context menu, select the option Add Layer. 

 
Figure 8 - Default User Layer Dialogue  
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In the dialogue, we will set a suitable name, chose a colour for the layer and set whether it is to be the active 
drawing layer we wish to use next. 
For the Name, we will use Shaft Holes. 

 
Figure 9 - Assigned name for the layer 

The two buttons below the Name section allow for you to Save or Load a specific User Layer set up. 
This will include the colour preference and Line Type which has previously been saved. 
This can save you time when you want to generate a standard layout. 
 
<LClick> on the [Edit] button to access the colour options. 

 
Figure 10 - Standard colour palette options. 

You may select any of the predefined colours by <LClick> on the colour square, or you can select by clicking 
on the larger colour palette area. 
 
Once you start to use this function more, you may wish to use the Add to Custom Colours to populate these 
for future use. 
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Select any colour you wish, with a word of caution. 

 
Figure 11 - Colours to avoid 

 On a default install of ALPHACAM, the two colours indicated in the image above have 
specific functionality and you should not use them. 

 
Once you have selected your colour, <LClick> [OK] to return to the User Layer set up dialogue. 
 

 
Figure 12 - Created layer dialogue set to Active 

Lastly on the dialogue make the  Active valid so that all your drawing creation will occur on this new layer. 
<LClick> [OK] to complete.
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Figure 13 - Project Manager with Active User Layer 

You can now see the new User Layer added, highlighted in blue and with a star to tell you this is your current 
active drawing layer. 
 

 
Figure 14 - ALPHACAM window Title Bar with Active Layer in brackets 

 It is worth noting that the active User Layer will also be shown in brackets on the Title 
Bar of your ALPHACAM window, saving you the trouble of having to look at the Project 
Manager every time you need to check. 

 

Create the geometry 

Select GEOMETRY > Circle > Centre + Diameter  
 
The command line will prompt you to enter the circle diameter. Type 20 <Enter>. 
Type 0,0 for the co-ordinates of the circle centre. 
The 20mm diameter circle will be drawn. 
The command line will again ask you for the circle diameter. 
Type 30 <Enter>. 
Type 100,0 for the co-ordinates of the circle centre. 
The 30mm diameter circle will be drawn. <RClick> to finish the command. 

 
Figure 15 - First two circles on the User Layer  
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Profiles 7 & 8 

 

Figure 16 - Profiles 7 & 8 

Create and activate the User Layer 
These next two profiles are part of a different section of the drawing, so require a new User Layer. 
 

 
Figure 17 - <RClick> options for a new User Layer 

Create the layer as shown below. 

 
Figure 18 - User Layer Main Pocket 

<LClick> [OK] to continue.  
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Create the geometry 
2 off circles 6mm larger radially than profiles 9 & 10. 
Create the walls around the two holes using the offset command. 

Select EDIT > Break Join etc. > Offset  

 
Figure 19 - Offset Dialogue 

Set the options as shown then [OK]. 
<LClick> the Ø20 circle, then <LClick> anywhere on the outside, the new profile will be drawn. 
<LClick> the Ø30 circle, then <LClick> anywhere on the outside, the new profile will be drawn. 
<RClick> to finish the command. 
 

 
Figure 20 - Created geometry on Main Pocket layer 

 Worth noting is the use of the Geometry option in the What section. 

 Either options, Line/Arc or Geometry will create a circle, but the Line/Arc option will be 
set as a Construction element. 
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Draw profile 6 
As this next section of geometry is also part of the Main Pocket, we carry on using the already active User 
Layer. 

 
Figure 21 - Profile 6 

Profile 6 is comprised of the following features; 
Figure of 8 with circles R38 & R82, with 3off R22 indents on Ø180 reference circle, 5mm fillets to indents plus 
2off 13mm fillets. 

Draw the R38 and R82 circles 
Prior to activating the next command ensure that Auto Snap <F2> is active. 
(Is the word Auto highlighted at the bottom right of the screen?). 

 
Figure 22 - Auto is shown at the bottom right of the screen 

To activate Auto Snap press <F2>. 

Select GEOMETRY > Circle > Centre + Radius  
The command line will prompt you to enter the circle radius. Type 38 <Enter>, position the cursor over the 
centre of profile 9 (the snap selector will be displayed). 

 
Figure 23 - Auto Snap marker to position the circle 

<LClick> to select this position. The 38mm radius circle will be drawn.  
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The command line will again prompt you for the circle radius. 
 
Type 82 into the dialogue, then position the cursor over the centre of profile 10 (the snap selector will be 
displayed) <LClick> to select this position.  
 
 
 

 
Figure 24 - The starting point for the main pocket detail 

 
The 82mm radius circle will be drawn. 
<RClick> to finish the command. 
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Main pocket Creation, Method 1 

Using the Unite command 

Select EDIT > Fabricate > Unite  
 

 
Figure 25 - Unite the two circles to complete the profile 

<LClick> the two large circles to select them, then <RClick> to finish the process and create the new profile. 
 

 
Figure 26 - Complete United profile as shown by a single Ghost Tool  
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Main pocket Creation, Method 2 

Using the Trim command 

Select EDIT > Break Join etc. > Trim  
The system will prompt TRIM: Select Cutting Geometries, <LClick> both circles to select them. 
 

 
Figure 27 - Circles selected for trimming 

<RClick>, <Esc> or <LClick> on the [Finish (ESC)] button to continue. 
The system will prompt TRIM: Pick Geometry/Toolpath to Trim, <LClick> the cursor on the two sections of 
the circles that are not required. 

 
Figure 28 - Sections of circle not required Trimmed away 

<RClick> to finish the command.  
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Join the profile 

Select <Ctrl> + <G> or VIEW > Display Options > Ghost Tools  to display the ghost tools. 
 

 
Figure 29 - Four ghost tools after using Trim 

Select EDIT > Break Join Etc. > Join  
<LClick> on each part of profile 6 so that it is all (selected) blue, <RClick> or press <Esc> this will action the 
command and if drawn properly profile 6 will only be displayed with one ghost tool. 
 

 
Figure 30 - Profile 6 joined.
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Create the indents 

To create the indent circles, we will use the Bolt Hole Circle command. 
This creates a number of equally spaced circles around a specified construction circle. 

Select GEOMETRY > Special Geometries > Bolt Hole Circle  
The following dialogue is displayed. Complete as shown. 
 

 
Figure 31 - Bolt Hole Circle Dialogue 

For the Circle Centre select the centre of profile 10 at X100 Y0. 
 

 
Figure 32 - Applied Bolt Hole Circles  
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Remove the circles from profile 6. 

Select EDIT > Fabricate > Subtract  
For the Geometries to Subtract to, <LClick> the bolt hole circle group. 
 

 
Figure 33 - Selecting the geometries to cut with 

 
 

 Note that creating the circles using the Special Geometries option automatically Groups 
the items to make selection easier in cases like this. 

 
<RClick> to finish this section of the command.  
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For the Geometries to Subtract from, <LClick> Profile 6, the combined figure of eight shape. 
 

 
Figure 34 - Selecting the geometries to be cut 

<RClick> to finish the command.  
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In the Project Manager Layers page. 

 
Figure 35 - Project Manager Layers 

<LClick> the small symbol next to the User Layers to expand those. 
Then <LClick> again on the small symbol next to * Main Pocket, then again on the small symbol next to the 
word Geometry to expand and make all the drawn items visible. 
 

 
Figure 36 - Expand Geometry 

<LClick> on Group 1 and keep the left mouse button held down to allow you to drag the group so that the 
word Construction second down from the top is highlighted, then release the left mouse button to move the 
geometries to the Construction layer. 
 

 
Figure 37 - Drag & Drop  
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There is nothing wrong in leaving the group on the main Construction layer if you wish. 
To place it onto the current active User Layer, you will need to perform the drag and drop function again to 
place it onto the required user layer. 
 

 
Figure 38 - Relocate form the Primary Construction layer 

<LClick> on Group 1 and keep the left mouse button held down to allow you to drag the group so that the 
word * Main Pocket is highlighted, then release the left mouse button to move the geometries to the 
Construction layer inside Main Pocket. 
 

 
Figure 39 - Correct layout 
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Figure 40 - Cutting circles as Construction entities 

Untick the Construction layer to turn off the construction elements. 

 It is good drawing practice to not delete items as you may need them for reference later. 
Moving them to different layers and then turning off those layers is a neater solution. 

 

 
Figure 41 - Construction entities turned off  
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An extra Ø44 circle is created because a circle was subtracted from within the bounding profile. 

Select EDIT > Delete  and select the redundant circle. <RClick> or <Esc> to complete the selection 
process, then [OK] to confirm deletion of the extra geometry circle. Lastly, <RClick> or <Esc> to finish the 
Delete command completely. 
 

 
Figure 42 - Completed profile ready to fillet application 
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Finalising the profile fillets 

Applying the main R5 Fillets 
The Fillet command is a very flexible tool allowing not just the application of fillets via the dialogue, but also the 
modification of existing fillets on a profile. 

Select EDIT > Break Join etc. > Fillet  
 

 
Figure 43 - Fillet Command Dialogue 

Enter 5 for the radius and select  All (as set by Ghost Tool) then <LClick> [OK]. 
<LClick> the newly created profile as the item to apply the fillets to. 
<RClick> to apply the fillets, <RClick> a second time to complete the command. 
 

 
Figure 44 - Applied R5 fillets  
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Adjusting the two R13 Fillets 

Select EDIT > Break Join etc. > Fillet  
 

 
Figure 45 - Fillet command dialogue to adjust the R13 items 

Setting the option to  Individual (Pick 2 elements) allows you to alter an existing fillet by <LClick> on the 
two elements each side of the existing filet and applying a new size. 
<LClick> the two arcs on each side of one of the R5 fillets that need to be adjusted to R13. 
 

 
Figure 46 - Selecting the two elements  

 
Figure 47 - Modified R13 fillet 

Repeat the above operation for the second R13 fillet modification. 
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Figure 48 - Completed main pocket detail 
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Draw profile 2 

 

Figure 49 - Profile 2 

Create and activate the User Layer 
The next profile is part of a different section of the drawing, so requires a new User Layer. 
 

 
Figure 50  -<RClick> options for a new User Layer 

 

 
Figure 51 - User Layer Oval Recess 

 
<LClick> [OK] to continue.  
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Draw the R55 and R102 circles 
Prior to activating the next command ensure that Auto Snap is active (is the word Auto highlighted at the 
bottom right of the screen?). To activate Auto Snap press <F2>. 

 
Figure 52 - Auto Snap active indicator 

Select GEOMETRY > Circle > Centre + Radius  
 
The command line will prompt you to enter the circle radius. 
Type 55 <Enter>, position the cursor over the centre of profile 1 (the snap selector will be displayed) <LClick> 
to select this position. The 55mm radius circle will be drawn. 
 
The command line will again ask you for the circle radius. 
Type 102 <Enter>, position the cursor over the centre of profile 2 (the snap selector will be displayed) 
<LClick> to select this position. The 102mm radius circle will be drawn. 
<RClick> to finish the command. 
 

 
Figure 53 - Large Circles applied  
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Add Tangent Lines 
Prior to creating the tangent lines ensure that Auto Snap is deactivated. 
To deactivate Auto Snap press <F2>. 

 
Figure 54 - Auto Snap off 

 

  Although it is not mandatory to turn off Auto Snap we do so because the Auto Snap only 
snaps to End, Mid, Centre & Quadrant points and it can be confusing when the position to 
be selected is a tangent point that could be very close to one of these locations. 

 

Select GEOMETRY > Line  
 
For the LINE From point press <F10>, the prompt will change to select circle or arc. 
 

 
Figure 55 - Tangent Line From 

 
Figure 56 - Tangent from point 

Select a position as shown above.  
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The elastic cursor line will be displayed, and this will remain tangent to the R55 circle as it is moved. 
 

 
Figure 57 - Elastic Cursor Line 

 
For the LINE to point press <F10> again. 
The prompt will change to select circle or arc. 
 

 
Figure 58 - Second selection point 

 
Select a position as shown above. 
The tangent line will be created <RClick> or press <Esc> to finish the line command.  
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Press <Space> to reactivate the Line command. 
 
For the LINE From point press <F10> the prompt will change to select circle or arc. Select a position towards 
the bottom left of the R55 circle. 
 

 
Figure 59 - Second Tangent Line start point 

The elastic cursor line will be displayed, and this will remain tangent to the R55 circle as it is moved. 
For the LINE To point press <F10> the prompt will change to select circle or arc. Select a position towards the 
bottom right of the R102 circle. 
 

 
Figure 60 - Second Tangent Line end point 

The tangent line will be created <RClick> or press <Esc> to finish the line command.  
 

 Note that the snap options are non-modal (single hits) and need to be selected each 
time you wish to use them.  
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Trim the Circles to the Lines 

Select EDIT > Break Join etc. > Trim  
The system will prompt TRIM: Select Cutting Geometries, <LClick> both tangent lines (they should turn 
blue). 

 
Figure 61 - Select Trimming Geometries 

Press <Esc> or <RClick> or select the [Finish (ESC)] button. 
The system will prompt TRIM: Pick Geometry/Toolpath to Trim, <LClick> the cursor on the portion of the 
circles to be removed. 

 
Figure 62 - Sections of unwanted circles removed 

<RClick> to finish the command.  
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Join the profile 

Select <Ctrl> + <G> or View > Display Options > Ghost Tools  to display the ghost tools 
 

Select EDIT > Break Join Etc. > Join  
 
<LClick> on each part of profile 2 so that it is all (selected) blue, <RClick> or press <Esc> this will action the 
Join command and if drawn properly profile 2 will only be displayed with one ghost tool. 
 

 
Figure 63 - Ghost tools display one complete profile to machine 
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Create profile 3 
Profile 3 comprises of 9 holes of Ø6 equally spaced on a profile 8mm inside of profile 2 starting at left most 
quadrant point. 
 

 

Figure 64 - Profile set 3 

Create and activate the User Layer 
The next profile is part of a different section of the drawing, so requires a new User Layer. 

 
Figure 65 - -<RClick> options for a new User Layer 

 

 
Figure 66 - User Layer 6mm Holes 

<LClick> [OK] to continue.  
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Offset profile 2. 

Select EDIT > Break Join etc. > Offset  
 

 
Figure 67 - Offset Dialogue 

Set the options as shown then <LClick> [OK]. 
<LClick> profile 2 then <LClick> a point on the inside, the new profile will be drawn. 
 

 
Figure 68 - Offset 8mm inside for the Equi-Spaced guide line 

<RClick> to finish the command.  
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Reset the Start point 
The Equi-Spaced Holes command uses the Start point of the selected geometry to place the First hole. To 
ensure the correct orientation of the holes we need to make sure that the Start Point for the last geometry we 
created is in the correct location. 

Select EDIT > Start Order > Start Pt  
 
Ensure that Auto Snap <F2> is active then <LClick> the Left most quadrant point on the new profile. 
 

 
Figure 69 - Setting the correct Start Point for Equi-Spaced holes 

 
<RClick> to finish the command. 
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Create the Equi-Spaced circles. 

Select GEOMETRY > Special Geometries > Equi-spaced holes  
 

 
Figure 70 - Equi-Spaced Holes command Dialogue 

 
Set the  Number of Holes to 9 and the Diameter of Holes to 6 then <LClick> [OK]. 
<LClick> the new profile to select it, then <RClick> to action the command. 
 

 
Figure 71 - Applied Equi-spaced circles  
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Managing the Drawing 

Using EDIT > Change  
 
Set the options as follows. 
 

 
Figure 72 - Change options Dialogue 

In the top section, select what the entity is at present,  Geometry. 
In the lower section select what you would like the entity to alter into,  Construction. 
<LClick> [OK] then, <LClick> the profile on which the holes were created. 
 

 
Figure 73 - Select the item to Change 

<RClick> to complete the process.  
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Figure 74 - Unticking construction 

 
Untick the main Construction Layer to then hide the Changed geometry and untick the 6mm Holes layer 
Construction section to hide the small marker lines for the hole centres. 
 

 
Figure 75 - Construction Geometry hidden.  
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Create profile 1  

 

Figure 76 - Profile set 1 

Create and activate the User Layer 
The next profile is part of a different section of the drawing, so requires a new User Layer. 
 

 
Figure 77  -<RClick> options for a new User Layer 

 

 
Figure 78 - User Layer Outer Profile 

 
<LClick> [OK] to continue.  
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Profile 1 comprises of a profile the same as profile 2, 8mm outside with Ø8 holes and R12 lugs with 5mm 
fillets. 

Offset profile 2. 

Select EDIT > Break Join etc. > Offset  
 

 
Figure 79 - Offset Dialogue 

Set the options as shown then [OK]. 
<LClick> profile 2 then <LClick> a point on the outside, the new profile will be drawn. <RClick> to finish the 
command. 

 
Figure 80 - The start of Profile 1  
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Hide unrequired geometries 
To make the process of selection easier and to avoid errors, we will hide all of the geometries that we are not 
going to work on. 
 
From the Project Manager, remove the tick from all the User Layers except Outer Profile. 
 

 
Figure 81 - Hiding Geometries by Unticking User Layers 
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Notes regarding the two offset profiles 

It should be noted at this point that there is an option in the EDIT > Break Join etc. > Offset  which 
would make the creation of the two offset profiles easier. 
The step by step option was used to guide you easily through the process. 
There is nothing from stopping you using the  Offset on both sides option in the first instance. 
 

 
Figure 82 - Offset on both sides option 

In doing this you would save yourself a few button clicks. 
 
 

 You must also make sure that you select the correct offset line for the creation of the 
Equi-Spaced circles. 
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Create one Hole & Lug 
Prior to using the next command ensure that Auto Snap is active (is the word Auto at the bottom right of the 
screen?). To activate Auto Snap press <F2>. 

Select GEOMETRY > Circle > Centre + Diameter  
 
The command line will prompt you to enter the circle diameter. 
Type 8 <Enter> then position the cursor over the left most end of profile 1 as shown, (the snap selector will be 
displayed) 
 

 
Figure 83 - Position of 8mm circle 

 <LClick> to select this position. The Ø8mm circle will be drawn. <RClick> to finish the command. 
 

 
Figure 84 - 8mm Circle created  
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Select GEOMETRY > Circle > Centre + Radius  
 
The command line will prompt you to enter the circle radius. 
Type 12 <Enter>, position the cursor as previous, (the snap selector will be displayed) <LClick> to select this 
position. The R12mm circle will be drawn. <RClick> to finish the command. 
 

 
Figure 85 - R12 Circle created 
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Copy Hole and Lug  

Select EDIT > Move Copy etc. > Copy  
 
<LClick> on the two circles (they should turn blue), then <RClick> or press <Esc>. 
 

 
Figure 86 - Select the items to Copy 

The system will prompt you to select the base point, using the auto snap functionality, <LClick> the centre 
point of the two selected circles. 
 

 
Figure 87 - Auto Snap to the centre of the two circles  
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The system will prompt you to Drag to Position or Enter Coordinates, type -18.47 <Enter> 61.54  
 

 
Figure 88 - Enter the first positions 

<LClick> [OK] both circles will be copied to the new position. 
 

 
Figure 89 - First copied holes 
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The system will prompt you to Drag to Position or Enter Coordinates, type 68.86 <Enter> 105.5. 
 

 
Figure 90 - Second copied holes 

<LClick> [OK] both circles will be copied to the new position.  
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For the third set using the auto snap, <LClick> the right most quadrant position on the outer profile, as shown 
below. 
 

 
Figure 91 - Location of final Copied circles 

 <RClick> to finish the placement options. <RClick> again to finish the command completely. 
 

 
Figure 92 - Copied Circles completed  
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Rotate Hole and Lug to 35° 

Select EDIT > Move Copy Etc. > Rotate  
 
<LClick> on the hole and lug circles on the right side to select them. 
 

 
Figure 93 - Circles to rotate 

<RClick> or Press <Esc> or <LClick> [Finish (ESC)]. 
The system will prompt you to select the Base Point. 
 
 
Figure 94 - Location point for rotation 

Using the auto snap <LClick> the centre point of the Ø30 circle.  
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The system will prompt you to select or enter the Rotation Angle (CW -ve). 
 

 
Figure 95 - Angle rotation options 

Type 35 into the dialogue box, then <LClick> [OK]. 
The system will prompt you How Many Copies (Including Original). 
 

 
Figure 96 - Number of rotational copies 

 
Type 1, then <LClick>[OK].  
The hole and lug will be rotated to their new position. <RClick> to finish the command.  
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Figure 97 - Primary circles created 
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Mirror Holes & Lugs 

Select EDIT > Move Copy Etc. > Mirror  
 
When prompted, <LClick> the items shown below for mirroring. 
 

 
Figure 98 - Select items to Mirror 

<RClick> or Press <Esc> or <LClick> [Finish (Esc)]. 
The system will prompt you to select the First Point on Mirror line. 
 

 
Figure 99 - First Mirror point 

<LClick> the location as shown above.  
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The system will prompt you to select the Second Point on Mirror line. 
 

 
Figure 100 - Second point of Mirror 

<LClick> the location as shown above. 
 
 

 You can select any 2 points that describe the mirror axis. Mirror only requires Vector 
direction so auto snapping to X0 Y0 for one point and then entering the value of 1 in the X 
option box will give the same results. 

 
 
The Mirror options dialogue is displayed as shown: 
 

 
Figure 101 - Keep Original when Mirroring 

Select the [Yes] option and the holes and lugs will be duplicated and mirrored. 
<RClick> or <Esc> to finish the command. 
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Figure 102 - Completed Mirror command 
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Trim and Join to create outer Profile 

Method 1 

Unite 

Select EDIT > Fabricate > Unite  
 
For the items to Unite, select the outer profile and the lug circle,  
 

 
Figure 103 - Unite outer profile 

 
<RClick> or Press <Esc> or <LClick> [Finish (ESC)]. 
The lugs and outer profile will be trimmed and joined to form the closed boundary. 
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Method 2 

Trim and Join 

Trim Lugs & Outer Profile 

Select EDIT > Break Join etc. > Trim  
 
For the cutting geometries select all the R12 circles and the outer profile. 
 

 
Figure 104 - Items to Trim 

<RClick> or Press <Esc> or <LClick> [Finish (Esc)] to continue. 
 
For the geometries to be Trimmed select all the inner parts of the R12 circles, then select the portions of the 
outer profile inside the lugs. 
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Figure 105 - Unwanted Geometries Trimmed away 

 Remember that Refresh or <Ctrl> + <R> or  can be used at any time. 
 
When the trimming is complete <RClick> or Press <Esc> to complete the process. 
 

Join outer profile Method 1 

Select EDIT > Break Join Etc. > Join  
 
Select the [Previous] button on the prompt line, this will select what was blue in the previous command, 
<RClick> or Press <Esc> to complete the command. 

Select <Ctrl> + <G> or View > Display Option > Ghost Tools  to display the ghost tools, ensure that 
there is only one on the outer profile. 
 

Join outer profile Method 2 

Select EDIT > Break Join Etc. > Join  
 
Select the [All] button on the prompt line, this will select all the visible geometries, <RClick> or <Esc> to 
complete the command. 

Select <Ctrl> + <G> or View > Display Option > Ghost Tools  to display the ghost tools, ensure that 
there is only one on the outer profile. 
 
Selecting other geometries that are not connected with the geometries being joined has no effect.  
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Fillet 5mm 
All the sharp corners in the outer profile can be filleted in one go. 

Select EDIT > Break Join etc. > Fillet  
 

 
Figure 106 - Filleting Options 

Set the options as shown then [OK]. 
Select the outer profile then <RClick> or Press <Esc> and the fillet radii will be created around the outer 
profiles’ sharp corners. 
 

 
Figure 107 - 5mm Fillet radii applied
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8mm Holes Layer 

To finally tidy up the drawing layers so far, we will create a User Layer for the 8mm circles. 
 

Create and activate the User Layer 

 
Figure 108  -<RClick> options for a new User Layer 

 

 
Figure 109 - User Layer 8mm Holes 

 
<LClick> [OK] to continue. 
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Alter the current Layer settings for the 8mm circles. 
While it is possible to use the Drag and Drop method we have seen earlier, there are a number of geometries 
that need adjusting so using the following method is easier. 

Using EDIT > Change  
 
Set the options as follows. 
 

 
Figure 110 - Changing layer status 

These settings maintain all sub layer settings within a User Layer structure. 
 
Construction will remain on Construction, Geometry on Geometry etc, but all of these elements will be 
relocated from the present location within the Layer tree structure, to the current active User Layer. 
 
<LClick> [OK] to continue. 
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As we have hidden all the other User Layers, when prompted for the items to change, use the [All] option at 
the bottom of the drawing area, 
 

 
Figure 111 - Use All to make selection easier 

Then <LClick> the Outer Profile, to deselect it. 
 

 
Figure 112 - Outer Profile deselected 

<LClick> [Finish (Esc)] to complete to change process.
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Figure 113 - Completed Change command 
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Draw Rapids 

Select VIEW > Display Options > Draw Geometry Rapids  
 
The Draw Rapids command shows the connections between the geometry start points in the order they were 
created. 

 
Figure 114 - Geometry Rapids showing the link between each geometry Start Point 

 
You can see that the order of the outer profile holes passes back across the part to the bottom set of holes; 
this is because the top holes were mirrored to create the bottom ones. 
 
This is the order in which the holes would be drilled. 
 
Whilst it is possible to reorder a series of tool paths, it is best practice to set the order of the geometries 
especially if the holes are to be machined more than once. i.e. Centre Drill, Drill, Tap and Chamfer.  
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Order Geometries. 

Select EDIT > Start Order. > Order  
 
This command allows you to reorder geometries or tool paths. 
 

 
Figure 115 - Ordering Dialogue 

Set the options as shown then select [OK]. 
The system prompts you to select the geometries <LClick> on each of the 8mm circles, when they are all blue 
<RClick> or Press <Esc>. 
 
 
Figure 116 - Items to re-order  
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 The order in which the geometries are selected does not affect this method, 
however, using the Manual option it would. 

 
The system requires you to select the geometry that will be the first in the pattern <LClick> on the left most Ø8 
mm circle. 

 
Figure 117 - Select the First in the set 

The geometries will be reordered. 

 
Figure 118 - Circles are re-ordered  
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Create profiles 4 & 5 

 

Figure 119 - Profile 4 & 5 

 

These next four geometries are part of the 6mm circle set. 
From the Project Manager page, turn on the Main Pocket user layer and the 6mm Holes. 
<RClick> on the 6mm Holes User Layer and make it Active. 
 

 
Figure 120 - Activate the 6mm circles layer 
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Ø6mm and Ø10mm holes at fillet centres 

Select GEOMETRY > Circle > Centre and Diameter . 
 
Enter 6 for the diameter then using auto snap or <F8> create the circles at the R13 Fillet centre. 
Enter 6 for the diameter then using auto snap or <F8> create the circles at the opposite R13 Fillet centre. 
 
Enter 10 for the diameter then using auto snap or <F8> create the circles at the R13 Fillet centre. 
Enter 10 for the diameter then using auto snap or <F8> create the circles at the opposite R13 Fillet centre. 
 

 To keep adding circles of the same size, left clicking in the drawing area has the same 
action as pressing Enter to accept the current radius or diameter value, or the same as 
<LClick> on the [OK] option. 

 

 
Figure 121 - Holes added to the centre of the R13 fillet 

 
 
<RClick> on the 6mm Holes user layer and select the Active option once more to de-activate the layer.  
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Profile 11, Text 

Create the Base Line 

For the Base line create an arc using ARC > Start + Second + End Points.  
 

 As the Text is printed from left to right, the direction of the base line needs to be also 
drawn left to right for the text to be positioned above the base line or right to left if the text is 
to be positioned below the base line 

 

Select GEOMETRY > Construction  to turn the construction option on. 

Select GEOMETRY > Arc > Start + Second + End Points  
Select the points as shown below. 

 
Figure 122 - Choice options for the 3 point Arc 

Ensuring that P1 and P3 are the corresponding positions above and below the centre line of the part, so that 
the midpoint of the created arc is midway across the right hand indent radius feature close to P2. 
 
<RClick> to complete the arc command.  
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Create the Text 

Select GEOMETRY > Text  
Set the options as shown in the Text dialogue. 
 

 
Figure 123 - Text creation Dialogue options 

<LClick> [OK] to continue and then <LClick> the previously created arc. 

 
Figure 124 - Select the arc to place the Text on  
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Enter the text to be engraved “Part No. 27854” 
Turn off the Construction layer to hide the reference arc.  
 

 
Figure 125 - Text positioned correctly 
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Just for clarification, if the construction Arc had been drawn in the opposite direction, selecting the lower point 
first and working in a CCW direction, the text would be placed as below. 
 

 
Figure 126 - Text positioned incorrectly 

 Take care when creating base line items for Text applications. 
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Position the Geometry for Machining 

Create the material 

 Please note that the use of Materials by either of the following methods is not available 
in the Essential level of the software. 

 

Use the 3D > Auto Set Material  Macro. 
 (Unavailable in the Essential level of the software.)  
 

 
Figure 127 - Auto Set Material options Dialogue 

This can be switched on via the Add-Ins/Macros > Add Ins  
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In the Add-Ins manager dialogue on the left hand listing, tick the  Create Default Material option to make 
this command active in the 3D tab. 
 

 
Figure 128 - Add-In manager dialogue 

 
 
 

 
Figure 129 - Housing Plate with added material 

 One thing to note is that the XY Stock option is applied to all four sides of the Auto Set 
Material. If you needed differing allowances, then the following method or similar would 
need to be used.  
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Manually create the material geometry and define the material 

Select GEOMETRY > Special Geometries > Enclosing Rectangle  
 
Select the outer profile then <RClick> and the enclosing rectangle is drawn. 
 

 
Figure 130 - Enclosing Rectangle using Construction Geometry 

Select EDIT > Break Join etc. > Offset  
 
Set the Offset Value to 6, the option to  Geometry, and check  Delete Original 
 then <LClick> [OK]. 
Select the enclosing rectangle then a point on the outside, the new rectangle will be drawn. 
 

 
Figure 131 - Rectangle adjusted to suit actual material form  
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Set the Material 

Select 3D > Set Materials  
Select the rectangle and the dialogue will be displayed. 
 

 
Figure 132 - Set Materials Dialogue options 

 
Set the options for the Material Top Z to 0 and the Material Bottom Z to -18. 
Select [OK]. 
 
 

 With either of these options it is possible to assign a texture image to the material to 
simulate the appearance of an actual material. 

 

 The default location for these images is “…. LICOMDAT/Textures” 

 Any standard image file can be used, BMP, JPG, PNG etc., the size of the image will 
dictate how the item will appear in ALPHACAM.  
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Move the job to a suitable position 

Select EDIT > Move Copy etc. > Move  
 
Select the [All] option on the prompt line then <RClick>. 
For the Base point using the auto snap select the lower left corner of the rectangle. 
For the new position type 0,0 
 

 If you have any items hidden, you MUST make them visible when you move the part to 
the machining location or they will be left in the original positions. 

Set the ISO view 
This will enable you to see the geometry and material. 

Select VIEW > VIEWS > Iso  
 

 
Figure 133 - Part moved to correct location for machining 

Prior to saving the job ensure that the geometry profiles only have one ghost tool. 

Select <Ctrl> + <G> or View > Display Options > Ghost Tools  to display the ghost tools. 
 

Save the Job 

Select FILE > Save  
The save dialogue is displayed, Select the required location folder then enter Housing Plate as the job name.  
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Setting Geometry Z Levels 
If you wish to machine the component using Auto Z machining (Standard ALPHACAM and higher) then you 
will need to set the geometry Z Levels. 
 
This allows for a method of machining that takes the depth information directly from the drawing file rather than 
the user entering values in the machining dialogue options. 
 

Select 3D > Set Geometry Z Levels  
The system prompts you Select Geometries, <LClick> on Geometries 1, the outer 8mm holes, plus 
geometries 9, & 10 

 
Figure 134 - Items to select for first Z Level application 

Then <RClick>.  
In the Dialogue Set the Top Z = 0 and the Bottom Z = -18 then <LClick> [OK]. 

 
Figure 135 - Set Geometry Z Levels Dialogue 
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Continue with the remaining options as detailed below; 
 
<LClick> on Geometry 4 (the Ø6 circles on the R13 centres) then <RClick>.  
In the Dialogue Set the Top Z = -3 and the Bottom Z = -12 then <LClick> [OK]. 
 
<LClick> on Geometry 2 (the inner oval) then <RClick>.  
In the Dialogue Set the Top Z = 0 and the Bottom Z = -3 then <LClick> [OK]. 
 
<LClick> on Geometries 3 (the Ø6 Equi-Spaced circles) then <RClick>.  
In the Dialogue Set the Top Z = -3 and the Bottom Z = -10 then <LClick> [OK]. 
 
<LClick> on Geometry 5 (Ø10 circles) then <RClick>.  
In the Dialogue Set the Top Z = -3 and the Bottom Z = -3 then <LClick> [OK]. 
 
<LClick> on Geometries 6 (the shaped main pocket) then <RClick>.  
In the Dialogue Set the Top Z = -3 and the Bottom Z = -12 then <LClick> [OK]. 
 
<LClick> on Geometries 7 & 8 (the offset circles of the central set of four) then <RClick>.  
In the Dialogue Set the Top Z = 0 and the Bottom Z = -12 then <LClick> [OK]. 
 
<RClick> to finish the command. 
 

 
Figure 136 - Finished part with Geometry Z Levels applied 

 

 Note that you cannot assign Geometry Z Levels to the text on this drawing and the 
resulting machining method does not support Auto Z machining any way. 
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Version amendments 
 

 
V Amendment Description A Software Version Amended Date 
13 Minor text formatting alterations. 1 2020.1 02/10/2019 
13 Template altered to Hexagon branding 0 2020.0 15/03/2019 

 
  



ALPHACAM 2020.1 
Housing Plate 

  
 

 
 
 

 
 
 
 
ALPHACAM  
Floor Two Tel.+44 (0) 1189 226677 
No. One, Waterside Drive Email. alphacaminfo@hexagon.com 
Arlington Business Park Web. www.alphacam.com 
Theale  
Reading Support. support.alphacam.uk@hexagon.com 
Berkshire Portal. customers.ps.hexagonmi.com 
RG7 4SA  
United Kingdom  

 
 
 

 
 

 

mailto:alphacaminfo@hexagon.com
http://www.alphacam.com/
mailto:support.alphacam.uk@hexagon.com
https://customers.ps.hexagonmi.com/

	Copyright
	Conventions used in this manual
	Recommended Operating Systems and Hardware for ALPHACAM
	Supported Operating Systems
	ALPHACAM Minimum Specifications

	Hexagon Customer Portal
	ALPHACAM esupport
	THE PROCESS PLAN
	Drawing Layer Structure
	Constituent parts
	Order of Production



	CREATING THE GEOMETRY
	Profiles 9 & 10
	Create and activate the User Layer
	Create the geometry

	Profiles 7 & 8
	Create and activate the User Layer
	Create the geometry

	Draw profile 6
	Draw the R38 and R82 circles
	Main pocket Creation, Method 1
	Using the Unite command

	Main pocket Creation, Method 2
	Using the Trim command
	Join the profile

	Remove the circles from profile 6.
	Finalising the profile fillets
	Applying the main R5 Fillets
	Adjusting the two R13 Fillets

	Draw profile 2
	Create and activate the User Layer
	Draw the R55 and R102 circles
	Add Tangent Lines
	Trim the Circles to the Lines
	Join the profile

	Create profile 3
	Create and activate the User Layer
	Offset profile 2.
	Reset the Start point
	Create the Equi-Spaced circles.

	Managing the Drawing
	Create profile 1
	Create and activate the User Layer
	Offset profile 2.
	Hide unrequired geometries
	Notes regarding the two offset profiles
	Create one Hole & Lug
	Copy Hole and Lug
	Rotate Hole and Lug to 35
	Mirror Holes & Lugs

	Trim and Join to create outer Profile
	Method 1
	Unite

	Method 2
	Trim and Join
	Trim Lugs & Outer Profile
	Join outer profile Method 1
	Join outer profile Method 2


	Fillet 5mm
	Create and activate the User Layer
	Alter the current Layer settings for the 8mm circles.

	Draw Rapids
	Order Geometries.
	Create profiles 4 & 5
	Ø6mm and Ø10mm holes at fillet centres

	Profile 11, Text
	Create the Base Line

	Create the Text

	Position the Geometry for Machining
	Create the material
	Manually create the material geometry and define the material
	Set the Material
	Move the job to a suitable position

	Set the ISO view
	Save the Job

	Setting Geometry Z Levels

